简单一点 2019-09-10 11:34:28 590次浏览 2条评论 4 5 0

继上次写的那个 《这是一个很干净的后台 (Yii2 + vue的权限管理 rabc)(想了解戳这里 http://www.yxpf120.com/code/1963 过去有一段时间了,觉得还是要把这个商城给弄完, 所以利用下班的时间 断断续续地把这个商城写完了,虽说不是很完整、全面。但个人觉得,一般项目的商城是足够可用了。

先讲讲里面的实现的功能吧。完整的权限管理、商品的增删改查、商品的规格管理、订单管理、简单的物流、会员管理、文章管理、轮播图、商城积分管理。

快乐飞艇我个人觉得里面还算不错的功能; 一个是商品规格的管理,可以实现不同规格SPU的库存管理,并对规格做了分组,以适用于不同的分类,还是不错的。这里是借鉴了shopNC,但做了一些简化, 个人觉得更简单明了;

还有一个就是 账本(积分)的管理),这个是本人工作中用了几年的一个设计模型, 扩展性和操作性都是不错的,很适合用于,结算、分润、积分支付方面的项目。

权限管理这块也还是可以的,支持无限极角色操作,对于单商城的项目应该是足够用了。 微信和支付宝的项目里没有做,主要是因为没有账号,微信支付这块是比较简单的, 不清楚的可以看我以前写的微信支付的文章,主要是一个记录,方便以后查看。 微信支付文章地址

github地址: 码云gitee地址:

>算了不说了,看一下效果图吧

觉得很赞
亿速云
  • 评论于 2019-09-16 15:52 举报

    看着不错哦,收藏了

  • 评论于 2019-09-27 14:38 举报

    进入vueadmin进行npm install报错哦,是不是你的npm太低,还是我的太高了,我的npm是6.11.3最新的,一直没法npm install哦。

    7 条回复
    评论于 2天前 回复

    快乐飞艇我用6.9的没问题,是报什么错,这个版本应该不会有太大问题

    评论于 2天前 回复

    好像是有个包6.11.3没法加载吧,后来我把版本降为4.6.1就可以了

    评论于 2天前 回复

    哪个包,你是把这个包的版本降到4.6.1,还是npm版本

    评论于 2天前 回复

    同问,我也是遇到这个问题

    评论于 2天前 回复

    你看是哪个包报错,跟clao一样把版本降一下看

    评论于 2天前 回复

    就是后台vueadmin
    快乐飞艇 1、cd vueadmin

    2、安装依赖
        npm install
    

    第二步骤的时候报错

    评论于 2天前 回复

    快乐飞艇报什么错,我刚把npm 升级到了6.11.3也没报什么错啊

您需要登录后才可以评论。登录 | 立即注册